Identificação de um Software para refereciamento Bibliografico

Pybliographer
Tradução da página oficial http://pybliographer.org/
Pybliographer é um software para gerenciamento de banco de dados bibliográfico. Podemos usar sua interface gráfica (baseada no Gnome) que fornece potencialidades de edição. bom mecanismos de procura, inserção direta de referencias em LyX (editor de documentos - http://pt.wikipedia.org/wiki/Lyx) and Kile (editor Tex/Latex para ambientes KDE).

Ou podemos diretamente acessar suas funções e classes internas e extende-lo a muitos usos (geração de páginas HTML de acordo à procura bibliográfica). Suporta os seguintes formatos: BibTeX? , ISI, Medline, Ovid, Refer. Saiba mais sobre esses tipos de editores: http://br-linux.org/tutoriais/000895.html.

Pybliographer é licensiado sob a GNU GPL e disponível com seu código aberto. Foi resultado do trabalho de muitas pessoas. O software está documentado e vem no próprio pacote do Pybliographer, contudo existe um manual online em inglês.

No site http://freshmeat.net (site referência em análise de softwares livres), ele é bem avaliado, apesar de não ser popular. Possue versão estável e seu público alvo é o próprio usuário final, desktop, usuário Linux, principalmente. Ele foi programado em C e Python por 4 (quatro) desenvolvedores. No sourceforge.net, ele está disponível para download. As versões estáveis são 1.2.X e em desenvolvimento são 1.3.X. As versões 1.2.9 e 1.3.3 (mais baixada do que a versão estável no softpedia.com) podem ser encontradas também em http://linux.softpedia.com. Ele redireciona a página para o sourgeforce. Mas, a última versão estável é 1.2.10.

Os seguintes pacotes são exigidos para a versão estável pelo site oficial:

python-bibtex >= 1.2.2 (available at the same locations as pybliographer)
Python version >= 2.3
Glib version >= 2.0.x
GNU Recode version 3.5 or 3.6 with a patch (see the RecodeHelp? page for more information)
Gnome 2 version >= 2.4
gnome-python version >= 2.5
Pygtk version >= 2.4

O site oficial não informa se há e quais são os requisitos para a versão instável.

No site do softpedia.com informa que os seguintes são os requisitos para a versão instável:

· Python, version >= 1.5.2
· Glib, version >= 1.0.x
· GNU Recode, version 3.5 or 3.6 with a patch (see the Recode help page for more information)
· Gnome, version 2.x
· Gnome-Python, version >= 2.0

Teoricamente ele é pouco usado. Há diferenças de informações entre o site oficial e o softpedia.com quanto aos requisitos para instalação, enquanto no oficial ele informa 7 requisitos para a versão estável, no softpedia informa apenas uma: GTK+ version 2.4.x.

Baixei o software do sf.net (formato taz.gz), durante a primeira tentativa de instalação, deu a mensagem de que precisava de um módulo chamado "recode". Procurei por ele, encontrei e fiz seu download no sf.net (PyRecode? ).

http://linux.softpedia.com/get/Education/Pybliographic-14863.shtml (versão estável)

http://linux.softpedia.com/get/Science-and-Engineering/Visualization/Pybliographer-6280.shtml (versão instável)

http://freshmeat.net

http://sourceforge.net

-- FabricioSantana - 01 Mar 2007

Página Inicial >> TWikiUsers >> AlessandraRodrigues >> AtividadesFabricio >> Softwares_Catalogar_CdDvd
Editar Anexar Versões Mais...
Projeto Software Livre - Bahia
TableLess - Coerência, Simplicidade e Acessibilidade no código HTML TWiki - Ambiente Web Colaborativo %btXHTMLok% %btCSSok%
ultima revisão: r8 - 02 Mar 2007 - 15:52:21 - FabricioSantana?     |     Copyleft Faced-UFBA